KPN heeft een app uitgebracht voor telefoons en tablets waarmee je via je eigen WiFi verbinding live televisie kunt kijken. Veel zenders zijn op deze manier te bekijken, zonder dat je een KPN decoder of televisie nodig hebt. Onderstaande uitleg komt uit de tijd dat deze app alleen werkte wanneer je via je eigen wifi verbonden was. Inmiddels is deze restrictie niet meer van toepassing, maar de uitleg kan behulpzaam zijn voor iemand die om andere redenen graag via VPN een verbinding wil opzetten.

 Live uitzending

Wanneer je gebruik maakt van een eigen router oplossing, kun je een VPN server te activeren binnen je eigen netwerk. Hiermee kun je een aparaat van buiten laten inloggen op je netwerk, waarna het lijkt alsof het zich binnen je eigen netwerk bevindt. Een heel simpel te configureren VPN server is die gebasseerd op PPTP.

Schematisch overzicht

VPN

 

De configuratie gaat er van uit dat je minimaal de 'alleen internet' configuratie in je router hebt geconfigureerd. Onderstaande is een aanvulling daarop.
In tegenstelling tot de decoders hebben we hier niks te maken met het IPTV VLAN, aangezien kijken via een webbrowser over het normale internet verloopt.

Configuratie

# Maak de inkomende PPTP interface aan
#

/interface pptp-server
add name=pptp-in1 user=""
/interface pptp-server server
set enabled=yes max-mru=1460 max-mtu=1460

# Maak een account aan die toegang heeft tot deze PPTP server.
# Vul zelf een username / password in. Deze dien je later in de 'client' (telefoon) in te geven.
# Het remote-address is het IP adres wat de inkomende verbinding zal krijgen.
# Het local-address is het IP adres van de router.

/ppp secret
add local-address=192.168.10.250 name=<naam> password=<wachtwoord> profile=\
    default-encryption remote-address=192.168.10.130 service=pptp

# Voeg enkele firewall regels toe om toegang te geven tot de PPTP server via internet.
# Let op: wanneer je al regels in je firewall hebt zitten moet je zorgen dat deze nieuwe regels
# boven eventuele blokkeringen komen te staan!
# De INPUT chain is verkeer naar de router zelf. We openen hiermee dus het GRE protocol en TCP/1723.

/ip firewall filter
add chain=input dst-port=1723 protocol=tcp
add chain=input protocol=gre

De client

De VPN server is nu aktief. Bij wijze van test kun je nu via een PC (windows ondersteunt PPTP standaard) een VPN verbinding opzetten naar de router op het interne IP adres. Dit is een goede manier om te kijken of de configuratie goed gegaan is.
Zoek vervolgens een PPTP VPN client voor jouw telefoon.  Heb je een Android telefoon met root, dan is de app VPNRoot een goede keuze: deze vereist geen lockscreen pincode.

VPNRoot applicatie

Bij Host vul je het publieke IP adres in van je thuis aansluiting.
Username/Password is datgene wat je eerder in de server configuratie hebt ingegeven.
Met deze app is het zo dat, zolang de VPN verbinding open is, al het netwerk verkeer van de telefoon versleuteld via je thuis aansluiting loopt. Je kunt je apparatuur thuis bereiken en ook via je huis het internet op gaan. De IPTV app zal probleemloos werken, maar je kunt dit alles ook gebruiken om onveilige hotspots op publieke lokaties een stuk veiliger te maken of gewoon om op afstand toegang te krijgen tot je eigen interne netwerk.

Voor het kunnen bekijken van een uitzending is minimaal een goede 3G verbinding vereist. Hou rekening met je dataverkeer! Een TV uitzending verbruikt ongeveer 7MB per minuut. Heb je een databundel van 1GB, dan kun je dus zo'n 2 uur TV kijken per maand. Om deze reden is het gebruik van VPN waarschijnlijk het meest zinvol via een (publieke) hotspot zonder datalimiet.

(Houd er wel rekening mee dat de encryptie van PPTP niet langer beschouwd wordt als 'onkraakbaar', maar voor het kijken van TV is het meer dan voldoende.)